#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$"
Local $sString = "123456" & @CRLF & _
"123456, 456789, 987654" & @CRLF & _
"1" & @CRLF & _
"," & @CRLF & _
" " & @CRLF & _
"123456, 123456, 987654," & @CRLF & _
"123456, 123456" & @CRLF & _
"123456, 456789, 987654, 123456, 1234567" & @CRLF & _
"123456, 456789, 987654, 123456, 123456, 345678" & @CRLF & _
"1," & @CRLF & _
" ," & @CRLF & _
"," & @CRLF & _
"123,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")