const regex = /^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\d{6})(?:(?:,[^\\n]\\d{6}){1,})?)$', 'gm')
const str = `123456
123456, 456789, 987654
1
,
123456, 123456, 987654,
123456, 123456
123456, 456789, 987654, 123456, 1234567
123456, 456789, 987654, 123456, 123456, 345678
1,
,
,
123,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}