# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$"
test_str = ("123456\n"
"123456, 456789, 987654\n"
"1\n"
",\n"
" \n"
"123456, 123456, 987654,\n"
"123456, 123456\n"
"123456, 456789, 987654, 123456, 1234567\n"
"123456, 456789, 987654, 123456, 123456, 345678\n"
"1,\n"
" ,\n"
",\n"
"123,")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.