$re = '/^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$/m';
$str = '123456
123456, 456789, 987654
1
,
123456, 123456, 987654,
123456, 123456
123456, 456789, 987654, 123456, 1234567
123456, 456789, 987654, 123456, 123456, 345678
1,
,
,
123,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);