import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\d{6})(?:(?:,[^\\n]\\d{6}){1,})?)$";
final String string = "123456\n"
+ "123456, 456789, 987654\n"
+ "1\n"
+ ",\n"
+ " \n"
+ "123456, 123456, 987654,\n"
+ "123456, 123456\n"
+ "123456, 456789, 987654, 123456, 1234567\n"
+ "123456, 456789, 987654, 123456, 123456, 345678\n"
+ "1,\n"
+ " ,\n"
+ ",\n"
+ "123,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}