re = /^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$/m
str = '123456
123456, 456789, 987654
1
,
123456, 123456, 987654,
123456, 123456
123456, 456789, 987654, 123456, 1234567
123456, 456789, 987654, 123456, 123456, 345678
1,
,
,
123,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end