package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\d{6})(?:(?:,[^\n]\d{6}){1,})?)$`)
var str = `123456
123456, 456789, 987654
1
,
123456, 123456, 987654,
123456, 123456
123456, 456789, 987654, 123456, 1234567
123456, 456789, 987654, 123456, 123456, 345678
1,
,
,
123,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}