# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\s\S]*(testreg)[\s\S]*//gm;t' <<< "{
\"testreg\":{
\"test1\":\"test2\",
\"test3\":\"test4\"
}
}"