package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\S]*(testreg)[\s\S]*`)
var str = `{
"testreg":{
"test1":"test2",
"test3":"test4"
}
}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}