const regex = /[\s\S]*(testreg)[\s\S]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\S]*(testreg)[\\s\\S]*', 'gm')
const str = `{
"testreg":{
"test1":"test2",
"test3":"test4"
}
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);