#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\s\S]*(testreg)[\s\S]*"
Local $sString = "{" & @CRLF & _
""testreg":{" & @CRLF & _
""test1":"test2"," & @CRLF & _
""test3":"test4"" & @CRLF & _
"}" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)