use strict;
my $str = '{
"testreg":{
"test1":"test2",
"test3":"test4"
}
}';
my $regex = qr/[\s\S]*(testreg)[\s\S]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";