// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\s\S]*(testreg)[\s\S]*").unwrap();
let string = "{
\"testreg\":{
\"test1\":\"test2\",
\"test3\":\"test4\"
}
}";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}