$re = '/[\s\S]*(testreg)[\s\S]*/m';
$str = '{
"testreg":{
"test1":"test2",
"test3":"test4"
}
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;