re = /[\s\S]*(testreg)[\s\S]*/m
str = '{
"testreg":{
"test1":"test2",
"test3":"test4"
}
}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result