#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>"
Local $sString = "<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")