$re = '/<actor=(\w+)(\s(?\'kword1\'\w+)(=(?\'val1\'\w+))?)?(\s(?\'kword2\'.+?)(=(?\'val2\'\w+))?)?(\s(?\'kword3\'.+?)(=(?\'val3\'\w+))?)?(\s(?\'kword4\'.+?)(=(?\'val4\'.+?))?)?>/s';
$str = '<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);