use strict;
my $str = '<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">';
my $regex = qr/<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}