re = /<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>/
str = '<actor=vencil lookat=beatrice enter transfer=vencil set="Vencil 1">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end