// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<actor=(\w+)(\s(?'kword1'\w+)(=(?'val1'\w+))?)?(\s(?'kword2'.+?)(=(?'val2'\w+))?)?(\s(?'kword3'.+?)(=(?'val3'\w+))?)?(\s(?'kword4'.+?)(=(?'val4'.+?))?)?>").unwrap();
let string = "<actor=vencil lookat=beatrice enter transfer=vencil set=\"Vencil 1\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}