import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<actor=(\\w+)(\\s(?'kword1'\\w+)(=(?'val1'\\w+))?)?(\\s(?'kword2'.+?)(=(?'val2'\\w+))?)?(\\s(?'kword3'.+?)(=(?'val3'\\w+))?)?(\\s(?'kword4'.+?)(=(?'val4'.+?))?)?>";
final String string = "<actor=vencil lookat=beatrice enter transfer=vencil set=\"Vencil 1\">";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}