using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(url *\( *(['""]*))(.*?)\2 *\)";
string substitution = @"Subbed";
string input = @"url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url(""wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff"")
url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( ""wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff"" )
url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url(""wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff"")
url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( ""wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff"" )
url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}