$re = '/(url *\( *([\'"]*))(.*?)\2 *\)/';
$str = 'url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )';
$subst = "Subbed";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;