use strict;
my $str = 'url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url(\'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( \'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\' )';
my $regex = qr/(url *\( *(['"]*))(.*?)\2 *\)/p;
my $subst = 'Subbed';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";