# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(url *\( *(['\"]*))(.*?)\2 *\)"
test_str = ("url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
"url(\"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
"url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
"url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
"url ( \"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
"url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n"
"url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
"url(\"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
"url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
"url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
"url ( \"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
"url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )")
subst = "Subbed"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.