import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(url *\\( *(['\"]*))(.*?)\\2 *\\)";
final String string = "url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
+ "url(\"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
+ "url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
+ "url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
+ "url ( \"wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
+ "url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )\n"
+ "url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)\n"
+ "url(\"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\")\n"
+ "url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')\n"
+ "url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )\n"
+ "url ( \"wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff\" )\n"
+ "url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )";
final String subst = "Subbed";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}