import Foundation
let pattern = #"(url *\( *(['"]*))(.*?)\2 *\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url('wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( 'wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )
url(wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff)
url("wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff")
url('wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff')
url ( wp-content/plugins/accordions/assets/global/webfonts/fa-brands-400.woff )
url ( "wp-con)tent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff" )
url ( 'wp-cont)ent/plugins/accordions/assets/global/webfonts/fa-brands-400.woff' )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Subbed"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)