#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$"
Local $sString = "abCD99$%" & @CRLF & _
"CD99ab$%" & @CRLF & _
"#c7F" & @CRLF & _
"missingDigits(%^*&%" & @CRLF & _
"missing_upper_case34857634578$#%^$%^" & @CRLF & _
"MISSING_LOWER_#%^#$^&#$%3234234_CASE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")