using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$";
string input = @"abCD99$%
CD99ab$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578$#%^$%^
MISSING_LOWER_#%^#$^&#$%3234234_CASE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}