import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\\W)^.+$";
final String string = "abCD99$%\n"
+ "CD99ab$%\n"
+ "#c7F\n"
+ "missingDigits(%^*&%\n"
+ "missing_upper_case34857634578$#%^$%^\n"
+ "MISSING_LOWER_#%^#$^&#$%3234234_CASE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}