re = /(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$/m
str = 'abCD99$%
CD99ab$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578$#%^$%^
MISSING_LOWER_#%^#$^&#$%3234234_CASE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end