use strict;
my $str = 'abCD99$%
CD99ab$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578$#%^$%^
MISSING_LOWER_#%^#$^&#$%3234234_CASE';
my $regex = qr/(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}