$re = '/(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$/m';
$str = 'abCD99$%
CD99ab$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578$#%^$%^
MISSING_LOWER_#%^#$^&#$%3234234_CASE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);