const regex = new RegExp('(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\\W)^.+$', 'gm')
const str = `abCD99\$%
CD99ab\$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578\$#%^\$%^
MISSING_LOWER_#%^#\$^&#\$%3234234_CASE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}