import Foundation
let pattern = #"(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*\W)^.+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
abCD99$%
CD99ab$%
#c7F
missingDigits(%^*&%
missing_upper_case34857634578$#%^$%^
MISSING_LOWER_#%^#$^&#$%3234234_CASE
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)