# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.*lib)?([^\\.*]*)\\/$1\//gm;t' <<< "C:\folder0\folder1\folder2\libtest\folder3\folder4\folder5"