const regex = /(?:.*lib)?([^\\.*]*)\\/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*lib)?([^\\\\.*]*)\\\\', 'gm')
const str = `C:\\folder0\\folder1\\folder2\\libtest\\folder3\\folder4\\folder5`;
const subst = `$1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);