#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:.*lib)?([^\\.*]*)\\"
Local $sString = "C:\folder0\folder1\folder2\libtest\folder3\folder4\folder5"
Local $sSubst = "$1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)