use strict;
my $str = 'C:\\folder0\\folder1\\folder2\\libtest\\folder3\\folder4\\folder5';
my $regex = qr/(?:.*lib)?([^\\.*]*)\\/mp;
my $subst = '$1/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";