import re
regex = re.compile(r"(?:.*lib)?([^\\.*]*)\\", flags=re.MULTILINE)
test_str = "C:\\folder0\\folder1\\folder2\\libtest\\folder3\\folder4\\folder5"
subst = "$1/"
result = regex.sub(subst, test_str)
if result:
print(result)