$re = '/(?:.*lib)?([^\\\\.*]*)\\\\/m';
$str = 'C:\\folder0\\folder1\\folder2\\libtest\\folder3\\folder4\\folder5';
$subst = "$1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;