# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^ ]+)( and [^ ]+ )([^ ]+)/\1 \3\2\3/gm;t' <<< "John and Mary Jones"