#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^ ]+)( and [^ ]+ )([^ ]+)"
Local $sString = "John and Mary Jones"
Local $sSubst = "\1 \3\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)