use strict;
my $str = 'John and Mary Jones';
my $regex = qr/([^ ]+)( and [^ ]+ )([^ ]+)/mp;
my $subst = '\\1 \\3\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";