import Foundation
let pattern = #"([^ ]+)( and [^ ]+ )([^ ]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"John and Mary Jones"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \3\2\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)