$re = '/([^ ]+)( and [^ ]+ )([^ ]+)/m';
$str = 'John and Mary Jones';
$subst = "\1 \3\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;