package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^ ]+)( and [^ ]+ )([^ ]+)`)
var str = `John and Mary Jones`
var substitution = "\1 \3\2\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}