using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ ]+)( and [^ ]+ )([^ ]+)";
string substitution = @"\1 \3\2\3";
string input = @"John and Mary Jones";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}