re = /([^ ]+)( and [^ ]+ )([^ ]+)/m
str = 'John and Mary Jones'
subst = '\\1 \\3\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result