#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Z][a-z-]+)([A-Z][a-z-]+)"
Local $sString = "BorisovaSvetlana A.; KimHak Joong; PuXiaotao; LiuHung-wen*Liu-wenHung-wen*Liu-wen-benHung-wen-ben*PushpeshRajwanshi" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1, \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)